Homepage - RF Cafe
Webmaster: Kirt Blattenberger | KB3UON | Sitemap | ©1996-2014
Menu below is just a small sample of what is here!
 
Custom Search
More than 10,000 searchable pages indexed.
•−•  ••−•    −•−•  •−  ••−•  •
RF Cafe Morse Code >Hear It<

Low pass filter Problem - Help Needed - RF Cafe Forums

Because of the high maintenance needed to monitor and filter spammers from the RF Cafe Forums, I decided that it would be best to just archive the pages to make all the good information posted in the past available for review. It is unfortunate that the scumbags of the world ruin an otherwise useful venue for people wanting to exchanged useful ideas and views. It seems that the more formal social media like Facebook pretty much dominate this kind of venue anymore anyway, so if you would like to post something on RF Cafe's Facebook page, please do.

Below are all of the forum threads, including all the responses to the original posts.


 Post subject: Low pass filter Problem - Help Needed
Posted: Thu May 20, 2010 4:24 am 
 
Captain

Joined: Thu May 20, 2010 4:20 am
Posts: 11
I am trying to remove the 1st and 2nd harmonic from a transmitter I have designed in the 433mhz band. It puts out 17dbm.. The transmitter is all surface mount based around the SX1230 chip.

Ive built 2 low pass filters with SMA in and out connectors and tested them with a spectrum analyzer with tracking gen. Both perform well with less than 1 db of insertion attenuation at 433mhz and around 25 db at 860mhz.

The problem is when I test them with my transmitter there seems to be no visible reduction in the harmonics when viewed with the spec ann.

This makes absolutely no sense to me infact it even sounds ridiculous.

Has anyone got any ideas of where I’m going wrong.???


 
   
 
 Post subject: Re: Low pass filter Problem - Help Needed
Posted: Thu May 20, 2010 4:46 am 
 
Site Admin
 

Joined: Mon Jun 27, 2005 2:02 pm
Posts: 373
Location: Germany
Hello,

Can you make a picture or a schematic of your filters and post them here?

Have you built your filters on PCB or copper substrate?

This indeed sounds weird. However, I have experienced a similar thing when I was a rookie, I built a quadraplexer ( 4 different filters, 42 components in total) in the air (Not on PCB substrate), and then once everything worked well and I implemented the circuit on a PCB, I was surprised why the center frequencies have been shifted.

Please provide more information, so we can help you out.

_________________
Best regards,

- IR


 
   
 
 Post subject: Re: Low pass filter Problem - Help Needed
Posted: Thu May 20, 2010 5:26 am 
 
Captain

Joined: Thu May 20, 2010 4:20 am
Posts: 11
Hi IR

Here are some pics.

Both filters are on double sided board FR4.

One filter is discrete 3 coils 2 caps the other is a johanson SMD LPF

My first time for pics










 
   
 
 Post subject: Re: Low pass filter Problem - Help Needed
Posted: Thu May 20, 2010 6:01 am 
 
Site Admin
 

Joined: Mon Jun 27, 2005 2:02 pm
Posts: 373
Location: Germany
My first suggestions:

1. Could be a mismatch problem between the transmitter output and the filters.
Have you checked the transmitter's output retrun loss?

2. If I have seen correctly from your picture, the first filter starts with a series coil and there is no DC blocking capacitor.
Maybe there is a load (due to coupling) between the filter and the power supply of the transmitter's PA, which causes this erouneous behavior.

_________________
Best regards,

- IR


 
   
 
 Post subject: Re: Low pass filter Problem - Help Needed
Posted: Thu May 20, 2010 6:22 am 
 
Captain

Joined: Thu May 20, 2010 4:20 am
Posts: 11
Hi IR

Firstly thankyou for your quick reply.

I suppose there could be a mismatch with the TX. I’ve just assumed its at 50 ohms.

How can I measure the return loss of the TX??? Is it the same way as you measure the return loss of a antenna but looking back into the output of the TX
using a directional coupler.

I’ll check the schematic as well to see if it DC blocked I think it is.

I’ve left work for the day so ill have a good look tomorrow taking into account your suggestions.


 
   
 
 Post subject: Re: Low pass filter Problem - Help Needed
Posted: Thu May 20, 2010 6:30 am 
 
Site Admin
 

Joined: Mon Jun 27, 2005 2:02 pm
Posts: 373
Location: Germany
Yes you can measure the TX output as you suggested.

Although after taking a look at the device's data sheet, I think that the problem most certainly lies in the absence of a DC blocking capacitor. You can see in the data sheet that all the suggested filter stages begin with a DC blocking capacitor. So if you connect the filter directly without any DC blocking capacitor, there is no isolation between the DC path to the RF path.

_________________
Best regards,

- IR


 
   
 
 Post subject: Re: Low pass filter Problem - Help Needed
Posted: Thu May 20, 2010 6:45 am 
 
Captain

Joined: Thu May 20, 2010 4:20 am
Posts: 11
Hi IR

Im not sure which data sheet your looking im asuming the SX1230

So does every RFfilter stage need its own series capacitor. Even if there is one blocking dc near the PA.


 
  
 
 Post subject: Re: Low pass filter Problem - Help Needed
Posted: Thu May 20, 2010 7:30 am 
 
Site Admin
 

Joined: Mon Jun 27, 2005 2:02 pm
Posts: 373
Location: Germany
I took a look at the SX1230 data sheeet.

The first filter stage needs a DC block capacitor for sure.
For the second stage, it is optional, although I would connect one.

_________________
Best regards,

- IR


 
   
 
 Post subject: Re: Low pass filter Problem - Help Needed
Posted: Thu May 20, 2010 10:26 pm 
 
Captain

Joined: Thu May 20, 2010 4:20 am
Posts: 11
Hi IR

Here is picture showing the measured return loss of the input of the transmitter as you suggested.

Ive never thought about doing this before so not sure of the results or if ive even set it up correctly.

As you can see the dip in the trace is at 530 Mhz. The bright dot on the screen is the frequency counter position set at my transmit freq for reference.

Does this mean the tuned circuits on the output of the PA are off frequency.

Should the dip be at my TX Frequency of 434 Mhz for ultimate matching.

Regards





 
   
 
 Post subject: Re: Low pass filter Problem - Help Needed
Posted: Fri May 21, 2010 2:40 am 
 
Site Admin
 

Joined: Mon Jun 27, 2005 2:02 pm
Posts: 373
Location: Germany
Yes it should be like this if you are measuring the return loss.

Another thing you can measure is the frrequency response of the transmitter by using power meter. You should get +17dBm at 433MHz and the output power should reduce as you decrease the frequency.

Have you also checkec the values of the capacitors and inductors you are using?

_________________
Best regards,

- IR


 
   
 
 Post subject: Re: Low pass filter Problem - Help Needed
Posted: Fri May 21, 2010 2:50 am 
 
Captain

Joined: Thu May 20, 2010 4:20 am
Posts: 11
Hi IR

Quote:
Have you checked the values of the capacitors/coils you used?


The values are as per the reference design. I suppose i now need to tweak the values of each component to move the dip to my TX frequency.

Ive got no idea where to start but i suppose i could use RF sim and recreate the output circuit and see component does what to the return loss.

Any suggestions??


 
   
 
 Post subject: Re: Low pass filter Problem - Help Needed
Posted: Fri May 21, 2010 2:54 am 
 
Site Admin
 

Joined: Mon Jun 27, 2005 2:02 pm
Posts: 373
Location: Germany
Have you also tried what I suggested yesterday: To use a DC blocking capacitor (With the values suggested in the reference design for this specific output power and frequency)?

_________________
Best regards,

- IR


 
   
 
 Post subject: Re: Low pass filter Problem - Help Needed
Posted: Fri May 21, 2010 4:59 am 
 
Captain

Joined: Thu May 20, 2010 4:20 am
Posts: 11
Hi IR

I haven’t tried the blocking cap as yet. I sort of got stuck with testing the return loss of the transmitter and what implications that has and how i would go about shifting the freq.

Can you please comment more on this??

I cant see how a blocking cap would work if the DC is already blocked.. please note: " im no expert RF engineer", unless it has to do with isolation between RF stages. Ill try it on Monday when I’m back at work.. What value would you recommend?
I was thinking around the 33pf.

thanks for your input

regards


 
   
 
 Post subject: Re: Low pass filter Problem - Help Needed
Posted: Fri May 21, 2010 5:53 am 
 
Site Admin
 

Joined: Mon Jun 27, 2005 2:02 pm
Posts: 373
Location: Germany
Quote:
I cant see how a blocking cap would work if the DC is already blocked.. please note: " im no expert RF engineer", unless it has to do with isolation between RF stages. Ill try it on Monday when I’m back at work.. What value would you recommend?
I was thinking around the 33pf.


The DC is not blocked. The PA gets its DC supply internally. The DC dupply and the RF signal exist on the same internal node which is the output of the PA. When you do not have a DC blocking capacitor, what will happen is that the filter stage will influence on your PA supply directly, i.e. instead of only having a choke for the supply only you will have a filter network.

You can see that for any MMIC amplifier there are coil and DC blocking capacitor connected for the reason I mentioned above: To isolate the RF and the DC paths.

33pF should do the work, a higher value like 47pF, 56pF can also be used.

_________________
Best regards,

- IR


 
   
 
 Post subject: Re: Low pass filter Problem - Help Needed
Posted: Fri May 21, 2010 6:14 am 
 
Captain

Joined: Thu May 20, 2010 4:20 am
Posts: 11
Hi IR

I’m confused.

Here is a schematic of the RF stage. There is 33pf series cap. This is what i mean by its already DC blocked. I’m trying to add an extra filter on at the end.

Am I still missing something here?



 
   
 
 Post subject: Re: Low pass filter Problem - Help Needed
Posted: Fri May 21, 2010 6:57 am 
 
Site Admin
 

Joined: Mon Jun 27, 2005 2:02 pm
Posts: 373
Location: Germany
The circuit that you showed in your last post is OK, the blocking capacitor exist there.

I did not see this capacitor assembled in your filter and this is why I was asking.

But I assume that this capacitor is assembled on your PCB. If this is the case, then this is OK.

Please check that there is output of +17dBm at the transmitter's output. Then connect the filters and check the same.

Then let's continue forward.

_________________
Best regards,

- IR


 
   
 
 Post subject: Re: Low pass filter Problem - Help Needed
Posted: Sat May 22, 2010 4:59 am 
 
Captain

Joined: Thu May 20, 2010 4:20 am
Posts: 11
Hi IR

Popped into work today to gather some more info.

As you can see in the Spec Analyser photos with input attenuation set at -20db on full span;

Main Carrier at 434Mhz is +18dbm
First harmonic is -36dbm
The second Harmonic is -34dbm

In the first two photos the transmitter is connected directly and the second set the filter has been added.
As you can see the filter has little effect and yet when swept alone it shows some 30+db of attenuation. There lie my problem..

Photos Tx Only






Photos including Filter





 
   
 
 Post subject: Re: Low pass filter Problem - Help Needed
Posted: Sat May 22, 2010 4:23 pm 
 
Site Admin
 

Joined: Mon Jun 27, 2005 2:02 pm
Posts: 373
Location: Germany
It looks really like the filter has no effect on your transmitter's output.
Since the first and second harmonic are already attenuated by more than 50dB without using a filter.

My explanation is: The transmitter itself has good rejection of the first and second harmonics. Therefore, you do not see almost any impact by adding the filter.

Based on the pics you showed in the posts above, your filters also attenuates around 50dB, and this is why you see a negligible added value.

The filter is based on resonant (notch) and a tolerance in components values contribute to an offset in the notch frequency which causes insufficient attenuation.

If you want to achieve increased harmonics attenuation, you need a higher order filter and/or another filter topology.

_________________
Best regards,

- IR


 
   
 
 Post subject: Re: Low pass filter Problem - Help Needed
Posted: Sun May 23, 2010 7:39 am 
 
Captain

Joined: Thu May 20, 2010 4:20 am
Posts: 11
Hi IR

Sound like you’ve given up. Well thank you anyway for responding.

You have a least given me some ideas to pursue.

I don’t know if I agree about needing a higher order filter and what would that be anyway?? I’ve even tried the two filters in series with no luck..

I’m thinking it must have something to do with impedance of the transmitters output. Ie The transmitters mismatched output impedance is changing the filters characteristics.

I found the return loss measurement of the transmitter interesting as the dip is not on my transmit freq.. Do you think this needs fixing?

What’s your thoughts about the return loss measurement of the transmitter??


Regards


 
   
 
 Post subject: Re: Low pass filter Problem - Help Needed
Posted: Sun May 23, 2010 10:32 pm 
 
Colonel

Joined: Tue Apr 11, 2006 8:13 pm
Posts: 34
Hello,

Just out of curiosity. Did you try putting an attenuator in place of the filter? Do the amplitudes of the carrier and the 2 harmonics reduce by an equal amount?

Karthik


 
   
 
 Post subject: Re: Low pass filter Problem - Help Needed
Posted: Sun May 23, 2010 10:38 pm 
 
Site Admin
 

Joined: Sun Aug 03, 2003 2:02 pm
Posts: 308
Location: Erie, PA
Greetings Digital:

IR has been giving some great inputs. If you don't mind, I'll add a couple comments.

As you have noted already, the output of your Tx board is well within the spec sheet levels for 2nd and 3rd harmonics (1st harmonic is the fundamental, 2nd harmonic is the 1st overtone), so its is a pretty good bet that the output impedance is close enough to 50 ohms, or likely the harmonics would look much worse. Likewise, the filter is pretty close to 50 ohms or it wouldn't look as good, either. There can be phasing issues when cascading two filters without any matching between them, but that might not be what is at work here.

What might be happening is that the lack of improvement you are seeing in the harmonic suppression is due to harmonics being generated internally by the spectrum analyzer itself because of input overload. The filter might indeed be reducing the harmonics, only to have the SA re-create them internally. I do not know the maximum input power level for the TR4122B, but here is a simple test to rule out the too-much-input-power thing.

Add a 20 dB filter to the SA input with the filter attached to the Tx (Tx -> Filter -> 20 dB Atten -> SA Input). See if the 2nd and 3rd harmonics are reduced significantly more than what you are measuring now (relative to the reduced fundamental). If the SA input was in fact being saturated, backing off by 20 dB should pull it out enough to prevent internally generated harmonics from dominating the output.

If that doesn't do it, I'll think some more about it

_________________
- Kirt Blattenberger 
RF Cafe Progenitor & Webmaster


 
   
 
 Post subject: Re: Low pass filter Problem - Help Needed
Posted: Mon May 24, 2010 2:25 am 
 
Captain

Joined: Thu May 20, 2010 4:20 am
Posts: 11
Hi All

Thankyou for jumping on board.. This problem is sending me nutty as it makes no sense at all but there has to be an answer.

Ive just retested the circuits with a 20db external attenuator inserted as suggest by Kirt.

Absolutely no difference was seen except the fact that all levels were now down by 20db.

regards


 
   
 
 Post subject: Re: Low pass filter Problem - Help Needed
Posted: Tue May 25, 2010 12:22 am 
 
Colonel

Joined: Tue Apr 11, 2006 8:13 pm
Posts: 34
Is there a ground issue (improper ground or a ground loop) somewhere? This is really wierd...


 
   
 
 Post subject: Re: Low pass filter Problem - Help Needed
Posted: Tue May 25, 2010 12:26 am 
 
Colonel

Joined: Tue Apr 11, 2006 8:13 pm
Posts: 34
Is the carrier going to be at a fixed frequency? If so, if nothing else works, you might consider adding a bandstop filter to try to reduce those harmonics....


 
   
 
 Post subject: Re: Low pass filter Problem - Help Needed
Posted: Tue May 25, 2010 1:31 pm 
 
Site Admin
 

Joined: Sun Aug 03, 2003 2:02 pm
Posts: 308
Location: Erie, PA
Greetings Digital:

Desparate times call for desparate suggestions.

Have you tried flexing and twisting the filter board while watching the display? Also try mashing it between your thumb and fingers around the components.

If there is a cold or fractured solder joint or fractured capacitor to ground that just happens to make contact while testing the filter alone, but not with the Tx attached, that would be a plausible source to the problem.

I've seen stranger phenomena.

_________________
- Kirt Blattenberger 
RF Cafe Progenitor & Webmaster
 Post subject: Re: Low pass filter Problem - Help Needed
Posted: Tue May 25, 2010 10:19 pm 
 
Colonel

Joined: Tue Apr 11, 2006 8:13 pm
Posts: 34
Can you reduce the output amplitude of the Tx? Does the Tx have a builtin attenuator that you could tweak? I'm wondering if you were saturating the circuit or causing some sort of internal oscillation. I could be way of center here, but I'm just throwing out ideas




Posted  11/12/2012
A Disruptive Web Presence

Custom Search
Over 10,000 pages indexed! (none duped or pirated)

Read About RF Cafe
Webmaster: Kirt Blattenberger
    KB3UON

RF Cafe Software

RF Cascade Workbook
RF Cascade Workbook is a very extensive system cascaded component Excel workbook that includes the standard Gain, NF, IP2, IP3, Psat calculations, input & output VSWR, noise BW, min/max tolerance, DC power cauculations, graphing of all RF parameters, and has a graphical block diagram tool. An extensive User's Guide is also included. - Only $35.
RF system analysis including
frequency conversion & filters

RF & EE Symbols Word
RF Stencils for Visio

Product & Service Directory
Personally Selected Manufacturers
RF Cafe T-Shirts & Mugs

RF Cafe Software

Calculator Workbook
RF Workbench
Smith Chart™ for Visio
Smith Chart™ for Excel
Your RF Cafe Progenitor & Webmaster
Click here to read about RF CafeKirt Blattenberger... single-handedly redefining what an
                                 engineering website should be.

View the YouTube RF Cafe Intro Video Carpe Diem! (Seize the Day!)

5CCG (5th MOB): My USAF radar shop

Airplanes and Rockets: My personal hobby website

Equine Kingdom: My daughter Sally's horse riding website